If you want to keep using your pre-2012 Kindle, you need to update it right away

The new update is required for pre-2012 devices that haven’t connected to the Internet since Oct. 5 2015. Do it by Tuesday.

Failure to do so, the company warns, and you won’t be able to connect to Amazon’s Cloud, access the Kindle Store, or use any other services through the device. After March 22nd, you will also have to update the device manually, by downloading the patch and updating it through your computer.

[If You Want To Keep Using Your Kindle, You Need To Update It Immediately / Andrew Liptak / Gizmodo]

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.